Il back-end si blocca su alcune pagine di un sito secondario

Recentemente ho creato un sito Web esistente in un sito Web WordPress e ho aggiunto un nuovo sito come sottodirectory.

Nota: tutto ciò si verifica solo nell’unico sito secondario.

Il primo problema era che nessun script avrebbe caricato l’amministratore; nessun CSS, nessun JavaScript. Mi è stato detto di aggiungere define( 'CONCATENATE_SCRIPTS', false ); al mio wp_config.php , così ho fatto. Questo ha permesso lo styling ma poi ha causato questo:

Alcune pagine (praticamente tutto tranne la dashboard) mi daranno un errore net::ERR_CONNECTION_RESET . Su Chrome, si blocca. In Firefox, si dice “la connessione è stata ripristinata”. In Safari, mi dà una pagina vuota.

Quando prendo la define( 'CONCATENATE_SCRIPTS', false ); fuori da wp-config.php , carica le pagine senza gli stili e fornisce un errore più specifico: lo stesso ( net::ERR_CONNECTION_RESET ) ma specificamente da wp-admin/load-styles.php e wp-admin/load-scripts.php . Non ho idea del perché questo potrebbe essere.

Sul mio iPhone, l’errore dato è ERR_INCOMPLETE_CHUNKED_ENCODING , che onestamente fa sembrare che si tratti di un barfing. Quindi sì.

Questo sito secondario problematico non ha plugin triggersti ​​e solo un tema che ha funzionato perfettamente fino a questo punto su un altro sito Web.

Fornirei l’URL, ma dal momento che il problema è il back-end al 100%, non penso che sarebbe utile.

PRIMA DI ARRIVARE COME DUPLICATO:

  1. Sì, ho chiamato il mio host ed entrambi hanno resettato il server e aggiornato il mio PHP, nessuno dei quali ha aiutato.
  2. Sì, ho cancellato la cache e provato diversi browser.
  3. La soluzione di nessun altro ha aiutato, anche altre risposte da questo sito. Ho cercato su Google. Penso che sia un problema unico con un errore simile.

Qualche idea?

Solutions Collecting From Web of "Il back-end si blocca su alcune pagine di un sito secondario"

@BrettGoodrich Mi piacerebbe avere consigli migliori per te sulla base delle informazioni che hai fornito, ma sembra che tu possa ancora avere a che fare con alcuni problemi di configurazione del server, forse qualcosa di cui non hai nemmeno il controllo dato che è l’hosting condiviso.

Quando incontro problemi come questo mi piace provare una nuova installazione di WordPress solo per testare il server prima di iniziare il debug del mio codice. Se è ansible installare una nuova installazione multi-sito WP su quel server e ottenere un sito secondario online che fornisca un’area di test pulita.

Se vedi ancora il problema su un’installazione pulita, è molto probabile che si tratti di un problema del server. Se il problema scompare, la prossima cosa che proverei è importare tutto il contenuto del tuo sito nell’installazione pulita.

Potresti anche prendere in considerazione la possibilità di contattare il supporto tecnico presso il tuo host. Spero che questa informazione sia utile.